Jamf School System Requirements

Levels of Compatibility

The following table provides descriptions of the levels of compatibility for Jamf School testing and product issue support:

 

Compatibility Level

Testing

Product Issue Support

Recommended

Full compatibility
Jamf targets development and testing resources to configurations at this level.

Full

Jamf is committed to fixing product issues that arise at this level.

Minimum Supported

High compatibility
Most configurations at this level were previously recommended and are likely to work.

Partial

Jamf will attempt to fix product issues that arise at this level.

Computer and Mobile Device Management Only

Untested

Limited compatibility
Management is not actively removed, and computers and mobile devices should continue to be managed after Jamf School is upgraded. Some features may not be available or may no longer work.

None

Jamf will not fix product issues that arise at this level.

Computer and Mobile Device Management

The following table lists operating system requirements for managed computers and mobile devices:

 

macOS1

iOS

iPadOS

tvOS

watchOS

Recommended

macOS 10.15.x

iOS 13.x

iPadOS 13.x

tvOS 13.x

watchOS 7.x

 

Minimum Supported

 

macOS 10.14.x

iOS 13.x

iPadOS 13.x

tvOS 13.x

watchOS 6.x

macOS 10.13.x

iOS 12.x

 

tvOS 12.x

 

macOS 10.12.x

iOS 11.x

 

tvOS 11.x

 

 

Untested

 

 

macOS 10.11.x

iOS 10.x

 

tvOS 10.x

 

macOS 10.10.x

iOS 9.x

 

 

 

macOS 10.9.x

iOS 8.x

 

 

 

1. It is strongly recommended that you test management workflows in a non-production environment.

Web Browsers

The following table lists the browser requirements for enrollment and access to web applications:

 

macOS

iOS

Windows

Linux

Recommended

Safari

Safari

Chrome

Firefox

 

Minimum Supported

 

Chrome

 

Firefox

Chrome

Firefox

 

 

 

 

Untested

 

 

Internet Explorer 11

 

 

 

Microsoft Edge

 

Copyright     Privacy Policy     Terms of Use     Security
© copyright 2002-2020 Jamf. All rights reserved.