System Requirements

System Requirements for Jamf Now Account Creation and Access

Jamf Now is accessible on mobile devices, but initial account creation must be completed on a Mac or Windows computer due to the requirement of downloading files to exchange with Apple, including files to link Jamf Now with Apple's Automated Device Enrollment and volume purchasing. For the best experience, access your Jamf Now account on one of the following browsers:

  • Safari

  • Mozilla Firefox

  • Google Chrome

Note:

For Open Enrollment, iPad and iPhone must use Safari, as other browsers are not capable of opening the downloaded configuration profile.

System Requirements for Enrolled Devices

Jamf Now can manage mobile devices and computers with the following minimum OS requirement:

  • iPadOS 13

  • iOS 11

  • macOS 10.13

  • tvOS 11

We recommend keeping all devices up to date on the latest operating system, as some features of Jamf Now require the latest version.

Note:

Jamf Now does not currently have Apple Watch support. Data from apps and accounts that have been deployed from Jamf Now will not sync with Apple Watch.