重要なお知らせ

2021 年 12 月 15 日に更新

Memcached の変更要件を追加しました。

Jamf Pro 10.33.0 以降にアップグレートする際に Memcached の変更がクラスタ環境に必要

Jamf Pro 10.33.0 以降にアップグレードする際に、Memcached の構成エラーにより、Tomcat がクラスタ環境で起動するのが阻害されます。Tomcat を起動し、Jamf Pro のアップグレードを完了するには、path/to/jss/tomcat/webapps/ROOT/WEB-INF/classes/dal/memcached.properties に移動して、memcached.directory.timeToLiveSeconds=86400memcached.properties ファイルに追加する必要があります。

Jamf Pro 10.33.0 にアップグレードする際の起動時間の増加

Jamf Pro 10.33.0 にアップグレードする際、初期サーバ起動中に applications データベーステーブルに保存されている重複行は削除されます。この起動時間は 1 回だけ延長され、アプリケーションテーブルのサイズや現環境で使用されているハードウェアの種類に応じて数分から数時間かかります。起動プロセスを途中で中止しないでください。起動中の問題やご質問に関しては、Jamf サポートまでお問い合わせください。

リリースの通知履歴

以降のバージョン...変更または留意点説明

10.30.0

インクリメンタルアップグレードには以下の作業が必須です

Jamf Pro 10.28.x 以前のバージョンから Jamf Pro 10.30.0 以降に直接アップグレードできない場合があります。Jamf Pro 10.28.0 以前から Jamf Pro 10.30.0 以降へのアップグレードには、10.29.x への段階的なアップグレードが必要です。

10.30.0

Apple TV デバイスの名前変更

[PI-008988] により環境が影響を受けた場合、Jamf Pro 10.30.0 の変更には、10.30.0 以降にアップグレードした後、お使いの環境のApple TVデバイスの名前の変更が必要になる場合があります。

手動でデバイスのインベントリ情報を編集して、デバイス名を強制的に適用できます。詳細についてはJamf Pro 管理者ガイドMobile Device Inventory Information (モバイルデバイスインベントリ情報) を参照してください。

また、デバイス名を強制的に適用する PreStage Enrollments を使って、Jamf Proでデバイスを再登録することもできます。詳細については、Jamf Pro 管理者ガイドMobile Device PreStage Enrollments (モバイルデバイス Prestage Enrollment (事前登録)) を参照してください。

10.29.0

失敗した InstallApplicationMDM コマンドを消去する

ご使用の環境が [PI-009279] の影響を受けた場合、「INCOMPATIBILITY_REASON_MINIMUM_OS_VERSION」エラーを表示する失敗した InstallApplication MDM コマンドをすべて消去する必要があります。これは、Mass Action を使用して行えます。詳細については、Jamf Pro 管理者ガイドの「コンピュータのリモートコマンド」を参照してください。

10.28.0

Jamf Cloud とパッチ管理の TLS 変更

Jamf Cloud でホストされている環境において TLS 1.1 を介した接続が無効になっています。その結果、Jamf Pro へのすべてのインバウンド接続は、新しいバージョンの TLS を介してネゴシエートし、TLS 1.1 通信を防止します。

10.27.0

MySQL 5.7.8 以降が必須

Jamf Pro 10.27.0 はデータベースのパフォーマンスに関して MySQL 5.7.8 以降を必要とする拡張機能を搭載しています。それより前のバージョンの MySQL をインストールしている場合、Jamf Pro 10.27.0 以降にアップグレードすることができないため、まず MySQL 5.7.8 以降 (MySQL 8.0 を推奨します) にアップグレードする必要があります。

10.27.0

インクリメンタルアップグレードには以下の作業が必須です

現在、Jamf Pro 10.24.x 以前から Jamf Pro 10.27.0 以降にアップグレードする場合、Jamf Pro 10.25.0 への増分アップグレードが必要となります。Jamf Pro 10.26.0 でのデータベース変更に伴い、アップグレードに失敗するためです。アップグレードを試みると、メッセージ「Jamf Pro Startup Suspended (Jamf Pro 起動中断)」が表示されます。