Requirements

The Jamf Infrastructure Manager Installer requires a computer with the following:

  • One of the following operating systems:
    • Ubuntu Server 18.04 LTS
    • Red Hat Enterprise Linux 7.x
    • Windows Server 2019 (64-bit)
    • Windows Server 2016 (64-bit)
    • Windows Server 2012 (64-bit)
      Note:

      For Windows Server operating systems, .NET Framework 4.0 or later is required.

    • Windows Server 2022 (64-bit)
  • A 64-bit capable Intel processor
  • 2 GB of RAM
  • 300 MB of disk space available
  • Java 11 (For more information, see the Migrating to Java 11 and Installing Java and MySQL for Jamf Pro 10.14.0 or Later articles.)
  • 64-bit Java SE Runtime Environment (JRE) 11 for Windows x64

On the Jamf Pro server, the built-in CA or a trusted third-party CA must be configured.

In addition, you need a Jamf Pro user account with the ability to "Create", "Read", "Update," and "Delete" the "Infrastructure Manager Instances" Jamf Pro Server Object.

For information on creating a Jamf Pro user account, see Jamf Pro User Accounts and Groups.