Remarques importantes

Autorisations de connexion manuelle avec accès conditionnel

Dans une prochaine version de Jamf Pro, les intégrations d’accès conditionnel utilisant les connexions manuelles vous obligeront à détenir l’autorisation Application.Read.All pour Microsoft Graph afin de communiquer la conformité à Microsoft Endpoint Manager. Avant la publication de cette version, Jamf recommande de mettre à jour les autorisations de Microsoft Graph afin d’y inclure Application.Read.All. Pour plus d’informations sur la mise à jour des autorisations de Microsoft Endpoint Manager, consultez l’article Modifications apportées aux autorisations pour Microsoft Endpoint Manager.

Historique des notes par version

Commençons par la version...Changements ou autres considérationsDescription
10.37.0Noms de scripts en double

Lors de la mise à niveau vers Jamf Pro 10.37.0, les noms de scripts informatiques en double dans votre environnement seront renommés dans la base de données Jamf Pro. Les noms de scripts en double seront renommés selon le format suivant :

ScriptName _renamed_UUID

10.37.0

Fin de la prise en charge de l’hébergement du serveur Jamf Pro sur macOS

La prise en charge de l’hébergement du serveur Jamf Pro sur macOS a été abandonnée. Si vous voulez migrer votre serveur Jamf Pro depuis macOS vers Jamf Cloud, contactez l’équipe Jamf Customer Success. Si vous voulez conserver votre serveur Jamf Pro sur site, consultez les plateformes prises en charge dans le paragraphe « Environnement serveur Jamf Pro » de la section Configuration système requise.

10.37.0

Nouvelles versions de MySQL recommandées

Il est recommandé d’utiliser MySQL 8.0.28 avec Jamf Pro 10.37.0. Si vous utilisez une version de MySQL 5, nous vous recommandons la version MySQL 5.7.37.

10.36.0

Nouvelles versions de MySQL recommandées

Il est recommandé d’utiliser MySQL 8.0.27 avec Jamf Pro 10.36.0. Si vous utilisez une version 5 de MySQL, nous vous recommandons MySQL 5.7.36.

10.36.0

Privilèges supplémentaires requis pour Jamf Recon et Jamf Remote

Pour permettre aux utilisateurs Jamf Recon et Jamf Remote d’utiliser correctement ces applications, les administrateurs Jamf Pro devront leur accorder les privilèges suivants :
  • Les utilisateurs Jamf Recon ont à présent besoin des privilèges Lire les scripts, Créer des appareils mobiles, Créer des utilisateurs et Créer des ordinateurs.

  • Les utilisateurs Jamf Remote ont à présent besoin du privilège Lire les scripts.

10.33.0

Changement requis concernant Memcached pour les environnements en cluster

Une erreur de configuration Memcached empêche le lancement de Tomcat dans les environnements en cluster lors de la mise à niveau vers Jamf Pro 10.33.0 ou version ultérieure. Pour lancer Tomcat et terminer la mise à niveau de Jamf Pro, vous devez accéder à path/to/jss/tomcat/webapps/ROOT/WEB-INF/classes/dal/memcached.properties et ajouter memcached.directory.timeToLiveSeconds=86400 au fichier memcached.properties.

10.33.0

Augmentation du délai de démarrage lors d’une mise à niveau

Les lignes dupliquées figurant dans le tableau des bases de données des applications de l’inventaire de l’ordinateur seront supprimées au cours du premier démarrage du serveur, lors de la mise à niveau vers Jamf Pro 10.33.0. Cela engendre un démarrage plus long, qui aura lieu une seule fois. Le processus peut prendre de quelques minutes à plusieurs heures supplémentaires, selon la taille de votre tableau d’applications et le matériel utilisé dans votre environnement. Il est important que vous n’interrompiez pas le processus de démarrage. En cas de questions ou de problèmes lors du démarrage, contactez l’assistance Jamf.

10.30.0

Mise à niveau incrémentielle requise

Les mises à niveau directes de Jamf Pro 10.28.x ou version antérieure vers Jamf Pro 10.30.0 ou version ultérieure risquent d’échouer. Une mise à niveau incrémentielle vers la version 10.29.x est désormais requise pour les mises à niveau de Jamf Pro 10.28.0 ou version antérieure vers Jamf Pro 10.30.0 ou version ultérieure.

10.30.0

Renommer les appareils Apple TV

Si votre environnement a été affecté par le problème [PI-008988], les modifications apportées dans Jamf Pro 10.30.0 peuvent nécessiter de renommer les appareils Apple TV de votre environnement après la mise à niveau vers Jamf Pro 10.30.0 ou version ultérieure.

Vous pouvez modifier les données d’inventaire de l’appareil et appliquer le nom de l’appareil manuellement. Pour plus d’informations, consultez la section Données d’inventaire de l’appareil mobile du Guide de l’administrateur Jamf Pro.

Vous pouvez également réenrôler les appareils avec Jamf Pro à l’aide d’un enrôlement PreStage qui applique les noms des appareils. Pour plus d’informations, consultez la section Enrôlements PreStage de l’appareil mobile du Guide de l’administrateur Jamf Pro.

10.29.0

Mise à niveau incrémentielle requise

La mise à niveau depuis 10.29.x ou version antérieure nécessite une mise à niveau incrémentielle vers 10.30.x avant de passer à 10.31.0 ou version ultérieure, en raison d’une modification de la base de données qui pourrait entraîner l’échec des mises à niveau.

10.29.0

Effacer les commandes InstallApplicationMDM ayant échoué

Si votre environnement a été affecté par [PI-009279], vous devez supprimer toutes les commandes MDM InstallApplication échouées qui affichent l’erreur INCOMPATIBILITY_REASON_MINIMUM_OS_VERSION. Vous pouvez le faire en utilisant une action de masse. Pour plus d’informations, consultez la section Commandes à distance pour ordinateurs du Guide de l’administrateur Jamf Pro.