Jamf Pro System Requirements

Levels of Compatibility

The following table provides descriptions of the levels of compatibility for Jamf Pro testing and product issue support:

 

Compatibility Level

Testing

Product Issue Support

Recommended

Full compatibility
Jamf targets development and testing resources to configurations at this level.

Full

Jamf is committed to fixing product issues that arise at this level.

Minimum Required

High compatibility
Most configurations at this level were previously recommended and are likely to work.

Partial

Jamf will attempt to fix product issues that arise at this level.

Configurations that do not meet the minimum requirements have not been tested, but may work.

Computer and Mobile Device Management

The following table lists operating system requirements for managed computers and mobile devices:

 

macOS*

iOS

tvOS

Recommended

macOS 10.14.x

iOS 12.x

tvOS 12.x

Minimum Required

macOS 10.13.x

iOS 11.x

tvOS 11.x

macOS 10.12.x

iOS 10.x

 

macOS 10.11.x

iOS 9.x

 

* Also indicates macOS versions required to run Composer on Mac computers.

Web Browsers

The following table lists the browser requirements for enrollment and access to web applications:

 

macOS

iOS

Windows

Linux

Recommended

Safari

Safari

Chrome

 

Minimum Required

Chrome

 

Firefox

Chrome

Firefox

 

Microsoft Edge

 

 

 

Internet Explorer 11

 

Jamf Pro Server Environment

The following table lists the server and related services requirements for Jamf Pro on-premise environments and the Jamf Pro installers:

 

Server OS*

Tomcat Version

Database Configuration

Java

Recommended

Windows Server 2016

Tomcat 8.5.40 or later

MySQL 8.0 – InnoDB

OpenJDK 11

Ubuntu Server 18.04 LTS

 

 

 

macOS 10.14**

 

 

 

Red Hat Enterprise Linux 7.x

 

 

 

Minimum Required

Windows Server 2012 R2

 

MySQL 5.7 – InnoDB

Oracle Java 11

macOS 10.13**

 

MySQL 5.7 on Amazon RDS – InnoDB

 

 

 

MySQL 5.6 – InnoDB

 

* All compatible operating systems are 64-bit only.
** macOS is not recommended for clustered environments.

Note: Although you can install Jamf Pro on any server that meets the minimum requirements, the Jamf Pro Installers for Mac, Linux, and Windows have additional requirements. For more information, see the Jamf Pro Installation and Configuration Guide for your platform.

Copyright     Privacy Policy     Terms of Use     Security
© copyright 2002-2019 Jamf. All rights reserved.