Installation

Preparing to Upgrade

To ensure the upgrade goes as smoothly as possible, review the best practices, tips, and considerations explained in the following Knowledge Base articles:

It is also recommended that you review the Functionality Changes and Other Considerations section to determine if changes made to the Casper Suite since your last upgrade could impact your environment or require you to take action.

Upgrading the JSS

This section explains how to upgrade the JSS using the JSS Installers. If the JSS host server does not meet the JSS Installer requirements, you can install the JSS manually using the instructions in the Manually Installing the Jamf Software Server technical paper.

Jamf tests upgrades from v9.8 through the current version.

Installed Components

The following components are installed on the JSS host server by the JSS Installer:

  • JSS web application

  • JSS Database Utility

  • Apache Tomcat

To find out which version of Tomcat will be installed, see the Apache Tomcat Version Installed by the JSS Installer Knowledge Base article.

Note: To take full advantage of all new features, bug fixes, and enhancements available in the Casper Suite, it is recommended that you use the latest version of the JSS and the client applications. To upgrade the client applications, simply replace the existing applications with the latest version.

JSS Installer Requirements

JSS Installer for Mac

The JSS Installer for Mac requires the following:

  • Minimum operating systems:

    • macOS 10.7

    • macOS 10.8

    • macOS 10.9

  • Recommended operating systems:

    • macOS 10.10

    • macOS 10.11

    • macOS 10.12

    • macOS 10.13

In addition, you need the following:

JSS Installer for Linux

The JSS Installer for Linux requires the following:

  • Minimum operating systems:

    • Ubuntu 12.04 LTS Server (64-bit)

    • Red Hat Enterprise Linux (RHEL) 6.4, 6.5, 6.6, or 7.0

  • Recommended operating systems:

    • Ubuntu 14.04 LTS Server (64-bit)

    • Ubuntu 16.04 LTS Server (64-bit)

    • Red Hat Enterprise Linux (RHEL) 6.8

    • Red Hat Enterprise Linux (RHEL) 7.3

In addition, you need the following:

  • A 64-bit capable Intel processor

  • 2 GB of RAM

  • 400 MB of disk space available

  • One of the following operating systems:

    • Ubuntu 12.04 LTS Server (64-bit)

    • Ubuntu 14.04 LTS Server (64-bit)

    • Red Hat Enterprise Linux (RHEL) 6.4, 6.5, 6.6, or 7.0

  • Open Java Development Kit (OpenJDK) 7 or 8
    For installation information, go to http://openjdk.java.net/install/.

  • MySQL 5.6.x or 5.7.x (MySQL 5.7.x is recommended)
    You can download MySQL from:
    https://www.mysql.com/downloads/

  • Ports 8443 and 8080 available

JSS Installer for Windows

The JSS Installer for Windows requires the following:

  • Minimum operating systems:

    • Windows Server 2008 R2 (64-bit)

    • Windows Server 2012 (64-bit)

  • Recommended operating systems:

    • Windows Server 2012 R2 (64-bit)

    • Windows Server 2016 (64-bit)

In addition, you need the following:

Upgrading the JSS

Use the following instructions to upgrade a JSS hosted on Mac or Linux. To upgrade a JSS hosted on Windows, see Upgrading the JSS in the JSS Installation and Configuration Guide for Windows.

  1. Back up the current database using the JSS Database Utility.

  2. Copy the most current version of the JSS Installer for your platform to the server.

  3. Double-click the installer and follow the onscreen instructions to complete the upgrade.

Copyright | Privacy | Terms of Use | Security
© copyright 2002-2017 Jamf. All rights reserved.