Installation

Preparing to Upgrade

To ensure the upgrade goes as smoothly as possible, review the best practices, tips, and considerations explained in the following Knowledge Base articles:

It is also recommended that you review the What's Changed section to determine if changes made to Jamf Pro since your last upgrade could impact your environment or require you to take action.

Upgrading Jamf Pro

This section explains how to upgrade Jamf Pro using the Jamf Pro Installers. If the Jamf Pro host server does not meet the Jamf Pro Installer requirements, you can install Jamf Pro manually using the instructions in the Manually Installing Jamf Pro technical paper.

Jamf tests upgrades from the most recent major or minor version release to the current version.

Installed Components

The following components are installed on the Jamf Pro host server by the Jamf Pro Installer:

  • Jamf Pro web app (formerly the JSS web app)

  • Jamf Pro database utility (formerly the JSS database utility)

  • Apache Tomcat

To find out which version of Tomcat will be installed, see the Apache Tomcat Version Installed by the Jamf Pro Installer Knowledge Base article.

Note: To take full advantage of all new features, bug fixes, and enhancements available in Jamf Pro, it is recommended that you use the latest version of the Jamf Pro server and Jamf Pro apps. To upgrade the Jamf Pro apps, simply replace the existing apps with the latest version.

Jamf Pro Installer Requirements

Jamf Pro Installer for Mac

The Jamf Pro Installer for Mac requires the following:

  • Minimum operating systems:

    • macOS 10.7

    • macOS 10.8

    • macOS 10.9

    • macOS 10.10

    • macOS 10.11

  • Recommended operating systems:

    • macOS 10.12

    • macOS 10.13

In addition, you need the following:

Jamf Pro Installer for Linux

The Jamf Pro Installer for Linux requires the following:

  • Minimum operating systems:

    • Ubuntu 12.04 LTS Server (64-bit)

    • Red Hat Enterprise Linux (RHEL) 6.4

  • Recommended operating systems:

    • Ubuntu 14.04 LTS Server (64-bit)

    • Ubuntu 16.04 LTS Server (64-bit)

    • Red Hat Enterprise Linux (RHEL) 6.9

    • Red Hat Enterprise Linux (RHEL) 7.4

In addition, you need the following:

Jamf Pro Installer for Windows

The Jamf Pro Installer for Windows requires the following:

  • Minimum operating systems:

    • Windows Server 2008 R2 (64-bit)

    • Windows Server 2012 (64-bit)

  • Recommended operating systems:

    • Windows Server 2012 R2 (64-bit)

    • Windows Server 2016 (64-bit)

In addition, you need the following:

Upgrading Jamf Pro

Use the following instructions to upgrade a Jamf Pro server hosted on Mac or Linux. To upgrade a Jamf Pro server hosted on Windows, see Upgrading Jamf Pro in the Jamf Pro Installation and Configuration Guide for Windows.

  1. Back up the current database using the Jamf Pro database utility.

  2. Copy the most current version of the Jamf Pro Installer for your platform to the server.

  3. Double-click the installer and follow the onscreen instructions to complete the upgrade.

Copyright     Privacy     Terms of Use     Security
© copyright 2002-2018 Jamf. All rights reserved.